หน้าเว็บ

วันจันทร์ที่ 15 สิงหาคม พ.ศ. 2554

Howto change IP on Solaris 10

Ifconfig command  ใช้สำหรับตั้งค่าอุปกรณ์การ์ดเครือข่าย  ( network card )

1. Enable the network card
#ifconfig hme0 plumb
ifconfig -a command should show following type of output which means device is enabled and is ready to configure ip address and netmask :
hme0: flags=842 mtu 1500
inet 0.0.0.0 netmask 0
ether 3:22:11:6d:2e:1f



2. Configuring ipaddress and netmask and making the interface status as up .
#ifconfig hme0 192.9.2.106 netmask 255.255.255.0 up
#ifconfig -a will now show the ip address , netmask and up status as follows :
hme0: flags=843 mtu 1500
inet 192.9.2.106 netmask ffffff00 broadcast 192.9.2.255
ether 3:22:11:6d:2e:1f

The file /etc/netmasks is used to define netmasks for ip addresses .

127.0.0.1, is the standard loop back route and 127.0.0.0 is the default loopback ipaddress used by the kernel when no interface is configured this will be the only entry displayed by the system on invoking ifconfig -a command..


3. Configuring Virtual interface
Virtual interface can be configured to enable hme0 reply to more then one ip addresses. This is possible by using hme0 alias which can be configured by ifconfig command only . The new alias device name now becomes hme0:1 hme:2 etc.
#ifconfig hme0:1 172.40.30.4 netmask 255.255.0.0 up
ifconfig -a will show the original hme0 and alias interface :
hme0: flags=843 mtu 1500
inet 192.9.2.106 netmask ffffff00 broadcast 192.9.2.255
ether 3:22:11:6d:2e:1f
hme0:1: flags=842 mtu 1500
inet 172.40.30.4 netmask ffff0000 broadcast 172.40.255.255



4. Ip-forwarding
IP forwarding allows you to forward all requests coming for a certain port or URL to be redirected to a specified IP address.
ip forwarding becomes enabled automatically when system detects more then one interface at the booting time . The file involved is /etc/rc2.d/S69inet .
ipforwarding is on by default but can be turned off by following command :
#ndd -set /dev/ip ip_forwarding 0


5. Router Configuration
After interfaces and ipaddess have been configured the system needs a default router which will allow the machine to talk to world outside of local network .
You can specify a particular route for a particular address as in following example
#route add -net 10.0.0.0 -netmask 255.0.0.0 172.40.30.1 1
if the the destination ipaddess is not defined in this manner system forwards all requests to the default router .
default route is defined manually by editing /etc/defaultrouter file and putting router’s ipaddress entry in it. This file is read by /etc/rc2.d/S69inet file during the booting process and entry added to the routing table .
The route can be defined online also using routeadd command but the changes will be lost on reboot .To make changes permanent make sure to put an entry in /etc/defaultrouter.
#route add default 205.100.155.2 1
#route change default 205.100.155.2 1
The 1 at the end is the number of hops to the next gateway.
If an interface is not responding to the network, check to be sure it has the correct IP address and netmask , network cables are fine .

Thanks  :  adminschoice.com

วันศุกร์ที่ 27 พฤษภาคม พ.ศ. 2554

Howto check services on Solaris 10

ในการดูว่า services อะไรบ้าง กำลัง online ใช้คำสั่ง

#  svcs

หากต้องการดูรายละเอียด ใช้คำสั่ง

# svcs -l <service_name>

หากต้องการ enable service

svcadm enable <service_name

หากต้องการ disable  service 

svcadm disable  <service_name>

หากต้องการ restart service  ใช้คำสั่ง

# svcadm restart <service_name>


Thanks :  www.experts-exchange.com


**command line for check services on solaris 10

วันพฤหัสบดีที่ 26 พฤษภาคม พ.ศ. 2554

Howto exact .tar.gz on solaris 10/ubuntu .




solaris    :  gunzip -c file_name.tar.gz |tar xvf -




ubuntu :  tar -xzvf   file_name.tar.gz



Thanks : www.tek-tips.com

วันอังคารที่ 17 พฤษภาคม พ.ศ. 2554

Howto use basic find command unix/linux.

syntax : find where-to-look criteria what-to-do


ตัวอย่างต่อไปนี้เป็นการใช้คำสั่ง find เพื่อค้นหา file ที่มีชื่อ "Toneation" โดยค้นหาไฟล์ทั้งหมดของระบบ filesystem  ("/')  แล้วโชว์ขึ้นหน้าจอ

find / -name Toneation -type f -print


หรืออาจระบุ directory ที่ต้องการจะค้นหาโดยเฉพาะ เช่น /usr และ /home


find /usr /home -name Toneation -type f


หรือให้ค้นหาเฉพาะ current directory


find . -name Toneation -type f


หรือใช้ค้นหา  ไฟล์ที่มีหลายนามสกุล หรือขึ้นต้นด้วย Toneation เช่น Toneation1,Toneation.txt


find /usr -name "Toneation*" -type f


หรือใช้ค้นหา ไฟล์ที่ลงท้ายด้วยนามสกุลที่ต้องการ

find /usr/local -name "*.html" -type f

 
และกรณีปิด error message ให้เพิ่ม 2>/dev/null  ดังนี้



find / -name "Toneation" 2>/dev/null 
 
 
  
Thanks:  http://www.devdaily.com/  , content.hccfl.edu

วันพุธที่ 11 พฤษภาคม พ.ศ. 2554

Howto add user on Soloris 11.

How to add user on Soloris 11.


  ใช้   useradd เพื่อทำการ สร้าง user ใหม่

useradd -u 1002 -g sysadmin -m -d /home/export/toneation -s /bin/sh toneation
 กรณีมี user อยู่แล้ว ใช้ usermod เพื่อแก้ไขค่าอื่นๆ

usermod -c "Sysadmin" toneation
ทำการตั้งค่ารหัสผ่านด้วย passwd

passwd toneation

Remark :   Red คือ syntax  Blue คือ option
                
 
 
  
 ตัวอย่างการใช้งาน คำสั่ง useradd


ตัวอย่างการใช้งาน คำสั่ง passwd


ผลลัพท์ที่ได้จากการใช้งานคำสั่ง logins
 
usage: useradd [-u uid [-o] | -g group | -G group[[,group]...] |-d dir |
-s shell | -c comment | -m [-k skel_dir] | -f inactive |
-e expire | -A authorization [, authorization ...] |
-P profile [, profile ...] | -R role [, role ...] |
-K key=value | -p project [, project ...]] login
useradd -D [-g group | -b base_dir | -f inactive | -e expire
-A authorization [, authorization ...] |
-P profile [, profile ...] | -R role [, role ...] |
-K key=value ... -p project]
 
Thanks : http://www.unix.com